Simple Two-Way Active Measurement Protocol (STAMP) Extensions for Reflecting STAMP Packet IP Headers
draft-ietf-ippm-stamp-ext-hdr-17
Revision differences
Document history
| Date | Rev. | By | Action |
|---|---|---|---|
|
2026-10-15
|
17 | (System) | IANA Review state changed to IANA OK - Actions Needed from Version Changed - Review Needed |
|
2026-10-15
|
17 | Mohamed Boucadair | Placed on agenda for telechat - 2026-10-22 |
|
2026-10-15
|
17 | Mohamed Boucadair | Ballot has been issued |
|
2026-10-15
|
17 | Mohamed Boucadair | [Ballot Position Update] New position, Yes, has been recorded for Mohamed Boucadair |
|
2026-10-15
|
17 | Mohamed Boucadair | Created "Approve" ballot |
|
2026-10-15
|
17 | Mohamed Boucadair | IESG state changed to IESG Evaluation from Waiting for AD Go-Ahead |
|
2026-10-15
|
17 | Mohamed Boucadair | Ballot writeup was changed |
|
2026-10-15
|
17 | (System) | IESG state changed to Waiting for AD Go-Ahead from In Last Call |
|
2026-10-14
|
17 | (System) | IANA Review state changed to Version Changed - Review Needed from IANA OK - Actions Needed |
|
2026-10-14
|
17 | Rakesh Gandhi | New version available: draft-ietf-ippm-stamp-ext-hdr-17.txt |
|
2026-10-14
|
17 | Rakesh Gandhi | New version accepted (logged-in submitter: Rakesh Gandhi) |
|
2026-10-14
|
17 | Rakesh Gandhi | Uploaded new revision |
|
2026-10-14
|
16 | Xiao Min | Request for IETF Last Call review by PERFMETRDIR Completed: Has Nits. Reviewer: Xiao Min. Sent review to list. |
|
2026-10-13
|
16 | Shwetha Bhandari | Request for IETF Last Call review by INTDIR Completed: Ready with Issues. Reviewer: Shwetha Bhandari. Sent review to list. Submission of review completed at an … Request for IETF Last Call review by INTDIR Completed: Ready with Issues. Reviewer: Shwetha Bhandari. Sent review to list. Submission of review completed at an earlier date. |
|
2026-10-13
|
16 | Shwetha Bhandari | Request for IETF Last Call review by INTDIR Completed: Ready with Issues. Reviewer: Shwetha Bhandari. |
|
2026-10-13
|
16 | David Dong | IESG/Authors/WG Chairs: IANA has completed its review of draft-ietf-ippm-stamp-ext-hdr-16. If any part of this review is inaccurate, please let us know. IANA understands that, upon … IESG/Authors/WG Chairs: IANA has completed its review of draft-ietf-ippm-stamp-ext-hdr-16. If any part of this review is inaccurate, please let us know. IANA understands that, upon approval of this document, there are two actions that we must complete. First, in the STAMP TLV Types registry in the Simple Two-way Active Measurement Protocol (STAMP) TLV Types registry group located at: https://www.iana.org/assignments/stamp-tlv-types two new registrations are to be made as follows: Value: [ TBD-at-registration ] Description: Reflected IPv6 Extension Header Data Reference: [ RFC-to-be ] Value: [ TBD-at-registration ] Description: Reflected Fixed Header Data Reference: [ RFC-to-be ] Second, in the STAMP Sub-TLV Types registry also in the Simple Two-way Active Measurement Protocol (STAMP) TLV Types registry group located at: https://www.iana.org/assignments/stamp-tlv-types a single new registration is to be made as follows: Value: [ TBD-at-registration ] Description: IPv6 Extension Header Control TLV Used: Reflected Test Packet Control Reference: [ RFC-to-be ] We understand that these are the only actions required to be completed upon approval of this document. NOTE: The actions requested in this document will not be completed until the document has been approved for publication as an RFC. This message is meant only to confirm the list of actions that will be performed. For definitions of IANA review states, please see: https://datatracker.ietf.org/help/state/draft/iana-review Thank you, David Dong IANA Services Sr. Specialist |
|
2026-10-13
|
16 | (System) | IANA Review state changed to IANA OK - Actions Needed from IANA - Review Needed |
|
2026-10-13
|
16 | Wesley Eddy | Request for IETF Last Call review by TSVART Completed: Ready with Issues. Reviewer: Wesley Eddy. Sent review to list. |
|
2026-10-08
|
16 | Tero Kivinen | Request for IETF Last Call review by SECDIR is assigned to Mališa Vučinić |
|
2026-10-07
|
16 | Rakesh Gandhi | New version available: draft-ietf-ippm-stamp-ext-hdr-16.txt |
|
2026-10-07
|
16 | Rakesh Gandhi | New version accepted (logged-in submitter: Rakesh Gandhi) |
|
2026-10-07
|
16 | Rakesh Gandhi | Uploaded new revision |
|
2026-10-07
|
15 | Magnus Westerlund | Assignment of request for IETF Last Call review by TSVART to Michael Scharf was rejected |
|
2026-10-06
|
15 | Daniele Ceccarelli | Request for IETF Last Call review by OPSDIR is assigned to Per Andersson |
|
2026-10-06
|
15 | Marc Blanchet | Request for IETF Last Call review by ARTART Completed: Ready with Issues. Reviewer: Marc Blanchet. Sent review to list. |
|
2026-10-04
|
15 | Shwetha Bhandari | Request for IETF Last Call review by INTDIR is assigned to Shwetha Bhandari |
|
2026-10-03
|
15 | Peter Yee | Request for IETF Last Call review by GENART is assigned to Stewart Bryant |
|
2026-10-02
|
15 | Barry Leiba | Request for IETF Last Call review by ARTART is assigned to Marc Blanchet |
|
2026-10-01
|
15 | Morgan Condie | IANA Review state changed to IANA - Review Needed |
|
2026-10-01
|
15 | Morgan Condie | The following Last Call announcement was sent out (ends 2026-10-15): From: The IESG To: IETF-Announce CC: draft-ietf-ippm-stamp-ext-hdr@ietf.org, ippm-chairs@ietf.org, ippm@ietf.org, marcus.ihlar@ericsson.com, mohamed.boucadair@orange.com … The following Last Call announcement was sent out (ends 2026-10-15): From: The IESG To: IETF-Announce CC: draft-ietf-ippm-stamp-ext-hdr@ietf.org, ippm-chairs@ietf.org, ippm@ietf.org, marcus.ihlar@ericsson.com, mohamed.boucadair@orange.com Reply-To: last-call@ietf.org, ippm@ietf.org Sender: Subject: Last Call: (Simple Two-Way Active Measurement Protocol (STAMP) Extensions for Reflecting STAMP Packet IP Headers) to Proposed Standard The IESG has received a request from the IP Performance Measurement WG (ippm) to consider the following document: 'Simple Two-Way Active Measurement Protocol (STAMP) Extensions for Reflecting STAMP Packet IP Headers' as Proposed Standard The IESG plans to make a decision on this document in the coming weeks, and solicits last-call comments. Please send substantive comments to the last-call@ietf.org mailing list, with ippm@ietf.org copied, no later than 2026-10-15. Please retain the beginning of the Subject line to facilitate automated sorting. Abstract The Simple Two-Way Active Measurement Protocol (STAMP) and its optional extensions can be used for Edge-to-Edge (E2E) active measurements. In Situ Operations, Administration, and Maintenance (IOAM) data fields can be used for recording and collecting Hop-by- Hop (HBH) and E2E operational and telemetry information. This document extends STAMP to reflect IPv4/IPv6 headers as well as IPv6 extension headers for HBH and E2E active measurements, for example, using the IOAM data fields. The file can be obtained via https://datatracker.ietf.org/doc/draft-ietf-ippm-stamp-ext-hdr/ The following IPR Declarations may be related to this I-D: https://datatracker.ietf.org/ipr/6640/ https://datatracker.ietf.org/ipr/6409/ https://datatracker.ietf.org/ipr/6530/ |
|
2026-10-01
|
15 | Morgan Condie | IESG state changed to In Last Call from Last Call Requested |
|
2026-10-01
|
15 | Morgan Condie | Last call announcement was generated |
|
2026-10-01
|
15 | Magnus Westerlund | Request for IETF Last Call review by TSVART is assigned to Wesley Eddy |
|
2026-10-01
|
15 | Michael Scharf | Assignment of request for IETF Last Call review by TSVART to Michael Scharf was rejected |
|
2026-10-01
|
15 | Thomas Graf | Request for IETF Last Call review by PERFMETRDIR is assigned to Xiao Min |
|
2026-10-01
|
15 | Magnus Westerlund | Request for IETF Last Call review by TSVART is assigned to Michael Scharf |
|
2026-09-30
|
15 | Mohamed Boucadair | Requested IETF Last Call review by TSVART |
|
2026-09-30
|
15 | Mohamed Boucadair | Requested IETF Last Call review by PERFMETRDIR |
|
2026-09-30
|
15 | Mohamed Boucadair | Requested IETF Last Call review by OPSDIR |
|
2026-09-30
|
15 | Mohamed Boucadair | Requested IETF Last Call review by INTDIR |
|
2026-09-30
|
15 | Mohamed Boucadair | Last call was requested |
|
2026-09-30
|
15 | Mohamed Boucadair | Ballot approval text was generated |
|
2026-09-30
|
15 | Mohamed Boucadair | Ballot writeup was generated |
|
2026-09-30
|
15 | Mohamed Boucadair | IESG state changed to Last Call Requested from AD Evaluation::AD Followup |
|
2026-09-30
|
15 | Mohamed Boucadair | Last call announcement was changed |
|
2026-09-30
|
15 | Mohamed Boucadair | AD Review addressed in https://author-tools.ietf.org/iddiff?url2=draft-ietf-ippm-stamp-ext-hdr-15 Pending point: CURRENT: Both the Session-Sender and the Session-Reflector MUST NOT discard the received Session-Sender STAMP-Test packets … AD Review addressed in https://author-tools.ietf.org/iddiff?url2=draft-ietf-ippm-stamp-ext-hdr-15 Pending point: CURRENT: Both the Session-Sender and the Session-Reflector MUST NOT discard the received Session-Sender STAMP-Test packets when the TTL or IPv6 Hop Limit is not 255. I think this should be reworded to say that the packet MUST NOT be discarded ** only because ** it has TTL/Hop Limit = 255. |
|
2026-09-30
|
15 | (System) | Changed action holders to Mohamed Boucadair (IESG state changed) |
|
2026-09-30
|
15 | (System) | Sub state has been changed to AD Followup from Revised I-D Needed |
|
2026-09-30
|
15 | Rakesh Gandhi | New version available: draft-ietf-ippm-stamp-ext-hdr-15.txt |
|
2026-09-30
|
15 | Rakesh Gandhi | New version accepted (logged-in submitter: Rakesh Gandhi) |
|
2026-09-30
|
15 | Rakesh Gandhi | Uploaded new revision |
|
2026-09-29
|
14 | Mohamed Boucadair | https://mailarchive.ietf.org/arch/msg/ippm/31gCLnH4yU2YTXLK58UYr2RxVIs/ |
|
2026-09-29
|
14 | (System) | Changed action holders to Rakesh Gandhi, Tianran Zhou, Zhenqiang Li, Will Hawkins (IESG state changed) |
|
2026-09-29
|
14 | Mohamed Boucadair | IESG state changed to AD Evaluation::Revised I-D Needed from AD Evaluation |
|
2026-09-28
|
14 | Mohamed Boucadair | IESG state changed to AD Evaluation from Publication Requested |
|
2026-09-28
|
14 | Marcus Ihlar | # Document Shepherd Write-Up for Group Documents *This version is dated 4 July 2022.* Thank you for your service as a document shepherd. Among the … # Document Shepherd Write-Up for Group Documents *This version is dated 4 July 2022.* Thank you for your service as a document shepherd. Among the responsibilities is answering the questions in this write-up to give helpful context to Last Call and Internet Engineering Steering Group ([IESG][1]) reviewers, and your diligence in completing it is appreciated. The full role of the shepherd is further described in [RFC 4858][2]. You will need the cooperation of the authors and editors to complete these checks. Note that some numbered items contain multiple related questions; please be sure to answer all of them. ## Document History 1. Does the working group (WG) consensus represent the strong concurrence of a few individuals, with others being silent, or did it reach broad agreement? Broad agreement. 2. Was there controversy about particular points, or were there decisions where the consensus was particularly rough? Nothing especially controversial, good technical discussions. 3. Has anyone threatened an appeal or otherwise indicated extreme discontent? If so, please summarize the areas of conflict in separate email messages to the responsible Area Director. (It should be in a separate email because this questionnaire is publicly available.) no 4. For protocol documents, are there existing implementations of the contents of the document? Have a significant number of potential implementers indicated plans to implement? Are any existing implementations reported somewhere, either in the document itself (as [RFC 7942][3] recommends) or elsewhere (where)? There is one open source implementation mentioned in the draft. ## Additional Reviews 5. Do the contents of this document closely interact with technologies in other IETF working groups or external organizations, and would it therefore benefit from their review? Have those reviews occurred? If yes, describe which reviews took place. This is document is very much in IPPM territory, there has been a Performance metric directorate review that was very helpful in improving the document. Relations to intarea are superficial since while it's about reflecting IP headers there are no impacts on intermediate node behavior in terms of reading or processing headers. 6. Describe how the document meets any required formal expert review criteria, such as the MIB Doctor, YANG Doctor, media type, and URI type reviews. n/a 7. If the document contains a YANG module, has the final version of the module been checked with any of the [recommended validation tools][4] for syntax and formatting validation? If there are any resulting errors or warnings, what is the justification for not fixing them at this time? Does the YANG module comply with the Network Management Datastore Architecture (NMDA) as specified in [RFC 8342][5]? n/a 8. Describe reviews and automated checks performed to validate sections of the final version of the document written in a formal language, such as XML code, BNF rules, MIB definitions, CBOR's CDDL, etc. n/a ## Document Shepherd Checks 9. Based on the shepherd's review of the document, is it their opinion that this document is needed, clearly written, complete, correctly designed, and ready to be handed off to the responsible Area Director? The shepherd has found a possible wireformat issue in version 11 of the document. This issue has been communicated to the authors and the WG. Once this issue is resolved the document is ready to be handed off. UPDATE on version 14: The document has been updated based on shepherd and other reviews and now looks ready to be handed off. 10. Several IETF Areas have assembled [lists of common issues that their reviewers encounter][6]. For which areas have such issues been identified and addressed? For which does this still need to happen in subsequent reviews? This mechanism touches on possible MTU issues, and have solutions for it. Could be something for a TSVART reviewer to look at. 11. What type of RFC publication is being requested on the IETF stream ([Best Current Practice][12], [Proposed Standard, Internet Standard][13], [Informational, Experimental or Historic][14])? Why is this the proper type of RFC? Do all Datatracker state attributes correctly reflect this intent? Proposed Standard. This is an extension to a mature and largely deployed protocol. Datatracker state attributes reflect this intent correctly. 12. Have reasonable efforts been made to remind all authors of the intellectual property rights (IPR) disclosure obligations described in [BCP 79][7]? To the best of your knowledge, have all required disclosures been filed? If not, explain why. If yes, summarize any relevant discussion, including links to publicly-available messages when applicable. The WGLC includes a paragraph with an IPR disclosure reminder. No additional disclosures were made after that. 13. Has each author, editor, and contributor shown their willingness to be listed as such? If the total number of authors and editors on the front page is greater than five, please provide a justification. yes 14. Document any remaining I-D nits in this document. Simply running the [idnits tool][8] is not enough; please review the ["Content Guidelines" on authors.ietf.org][15]. (Also note that the current idnits tool generates some incorrect warnings; a rewrite is underway.) UPDATE on -14: Nits on -11 have been addressed. OLD: No structural nits found. A few issues with clarity in -11 discovered and have been communicated to the authors. Copied here for reference: Section 3.1.1 states that “without the Control Sub-TLV .. the Session-Reflector does not add IPv6 extension headers” Section 5.3 states: .. MAY not add new matching IPv6 extension headers .. This behaviour can be based on a local policy on the Session-Reflector. I read the first sentence such that the reflector does not add them based on having seen them in the packet. And the second sentence as “the reflector might add headers that happen to match those in the TLVs for other reasons”. But the first sentence could lead one to expect a MUST NOT in 5.3. I think some more text to clarify the intent here would be good. Also, “MAY not add” sounds a bit strange as a normative phrase, perhaps “MAY omit” or similar is a bit clearer. Section 7 discusses attack mitigation by performing timestamp validation, giving the example of comparing T2 and T1. This comparison requires clock synchronization, perhaps it’s good to mention that, or use other examples like T3 >= T2 or T1 < T4. 15. Should any informative references be normative or vice-versa? See the [IESG Statement on Normative and Informative References][16]. No, the classifications look correct. 16. List any normative references that are not freely available to anyone. Did the community have sufficient access to review any such normative references? n/a 17. Are there any normative downward references (see [RFC 3967][9] and [BCP 97][10]) that are not already listed in the [DOWNREF registry][17]? If so, list them. No 18. Are there normative references to documents that are not ready to be submitted to the IESG for publication or are otherwise in an unclear state? If so, what is the plan for their completion? No, I-D.ietf-ippm-asymmetrical-pkts is in RFC Editors queue. 19. Will publication of this document change the status of any existing RFCs? If so, does the Datatracker metadata correctly reflect this and are those RFCs listed on the title page, in the abstract, and discussed in the introduction? If not, explain why and point to the part of the document where the relationship of this document to these other RFCs is discussed. No. 20. Describe the document shepherd's review of the IANA considerations section, especially with regard to its consistency with the body of the document. Confirm that all aspects of the document requiring IANA assignments are associated with the appropriate reservations in IANA registries. Confirm that any referenced IANA registries have been clearly identified. Confirm that each newly created IANA registry specifies its initial contents, allocations procedures, and a reasonable name (see [RFC 8126][11]). The draft does not request creation of any new registries. It asks for two TLV types in the "STAMP TLV Types registry and one Sub-TLV Type in the STAMP TLV Type "Reflected Test Packet Control" (Type 12). It should be noted that this TLV type is defined in ietf-ippm-asymmetrical-pkts which is currently in RFC Editors queue. 21. List any new IANA registries that require Designated Expert Review for future allocations. Are the instructions to the Designated Expert clear? Please include suggestions of designated experts, if appropriate. n/a [1]: https://www.ietf.org/about/groups/iesg/ [2]: https://www.rfc-editor.org/rfc/rfc4858.html [3]: https://www.rfc-editor.org/rfc/rfc7942.html [4]: https://wiki.ietf.org/group/ops/yang-review-tools [5]: https://www.rfc-editor.org/rfc/rfc8342.html [6]: https://wiki.ietf.org/group/iesg/ExpertTopics [7]: https://www.rfc-editor.org/info/bcp79 [8]: https://www.ietf.org/tools/idnits/ [9]: https://www.rfc-editor.org/rfc/rfc3967.html [10]: https://www.rfc-editor.org/info/bcp97 [11]: https://www.rfc-editor.org/rfc/rfc8126.html [12]: https://www.rfc-editor.org/rfc/rfc2026.html#section-5 [13]: https://www.rfc-editor.org/rfc/rfc2026.html#section-4.1 [14]: https://www.rfc-editor.org/rfc/rfc2026.html#section-4.2 [15]: https://authors.ietf.org/en/content-guidelines-overview [16]: https://www.ietf.org/about/groups/iesg/statements/normative-informative-references/ [17]: https://datatracker.ietf.org/doc/downref/ |
|
2026-09-28
|
14 | Marcus Ihlar | IETF WG state changed to Submitted to IESG for Publication from WG Consensus: Waiting for Write-Up |
|
2026-09-28
|
14 | Marcus Ihlar | IESG state changed to Publication Requested from I-D Exists |
|
2026-09-28
|
14 | (System) | Changed action holders to Mohamed Boucadair (IESG state changed) |
|
2026-09-28
|
14 | Marcus Ihlar | Responsible AD changed to Mohamed Boucadair |
|
2026-09-28
|
14 | Marcus Ihlar | Document is now in IESG state Publication Requested |
|
2026-09-28
|
14 | Marcus Ihlar | Tag Other - see Comment Log cleared. |
|
2026-09-28
|
14 | Marcus Ihlar | Changed consensus to Yes from Unknown |
|
2026-09-28
|
14 | Marcus Ihlar | Intended Status changed to Proposed Standard from None |
|
2026-09-28
|
14 | Marcus Ihlar | # Document Shepherd Write-Up for Group Documents *This version is dated 4 July 2022.* Thank you for your service as a document shepherd. Among the … # Document Shepherd Write-Up for Group Documents *This version is dated 4 July 2022.* Thank you for your service as a document shepherd. Among the responsibilities is answering the questions in this write-up to give helpful context to Last Call and Internet Engineering Steering Group ([IESG][1]) reviewers, and your diligence in completing it is appreciated. The full role of the shepherd is further described in [RFC 4858][2]. You will need the cooperation of the authors and editors to complete these checks. Note that some numbered items contain multiple related questions; please be sure to answer all of them. ## Document History 1. Does the working group (WG) consensus represent the strong concurrence of a few individuals, with others being silent, or did it reach broad agreement? Broad agreement. 2. Was there controversy about particular points, or were there decisions where the consensus was particularly rough? Nothing especially controversial, good technical discussions. 3. Has anyone threatened an appeal or otherwise indicated extreme discontent? If so, please summarize the areas of conflict in separate email messages to the responsible Area Director. (It should be in a separate email because this questionnaire is publicly available.) no 4. For protocol documents, are there existing implementations of the contents of the document? Have a significant number of potential implementers indicated plans to implement? Are any existing implementations reported somewhere, either in the document itself (as [RFC 7942][3] recommends) or elsewhere (where)? There is one open source implementation mentioned in the draft. ## Additional Reviews 5. Do the contents of this document closely interact with technologies in other IETF working groups or external organizations, and would it therefore benefit from their review? Have those reviews occurred? If yes, describe which reviews took place. This is document is very much in IPPM territory, there has been a Performance metric directorate review that was very helpful in improving the document. Relations to intarea are superficial since while it's about reflecting IP headers there are no impacts on intermediate node behavior in terms of reading or processing headers. 6. Describe how the document meets any required formal expert review criteria, such as the MIB Doctor, YANG Doctor, media type, and URI type reviews. n/a 7. If the document contains a YANG module, has the final version of the module been checked with any of the [recommended validation tools][4] for syntax and formatting validation? If there are any resulting errors or warnings, what is the justification for not fixing them at this time? Does the YANG module comply with the Network Management Datastore Architecture (NMDA) as specified in [RFC 8342][5]? n/a 8. Describe reviews and automated checks performed to validate sections of the final version of the document written in a formal language, such as XML code, BNF rules, MIB definitions, CBOR's CDDL, etc. n/a ## Document Shepherd Checks 9. Based on the shepherd's review of the document, is it their opinion that this document is needed, clearly written, complete, correctly designed, and ready to be handed off to the responsible Area Director? The shepherd has found a possible wireformat issue in version 11 of the document. This issue has been communicated to the authors and the WG. Once this issue is resolved the document is ready to be handed off. UPDATE on version 14: The document has been updated based on shepherd and other reviews and now looks ready to be handed off. 10. Several IETF Areas have assembled [lists of common issues that their reviewers encounter][6]. For which areas have such issues been identified and addressed? For which does this still need to happen in subsequent reviews? This mechanism touches on possible MTU issues, and have solutions for it. Could be something for a TSVART reviewer to look at. 11. What type of RFC publication is being requested on the IETF stream ([Best Current Practice][12], [Proposed Standard, Internet Standard][13], [Informational, Experimental or Historic][14])? Why is this the proper type of RFC? Do all Datatracker state attributes correctly reflect this intent? Proposed Standard. This is an extension to a mature and largely deployed protocol. Datatracker state attributes reflect this intent correctly. 12. Have reasonable efforts been made to remind all authors of the intellectual property rights (IPR) disclosure obligations described in [BCP 79][7]? To the best of your knowledge, have all required disclosures been filed? If not, explain why. If yes, summarize any relevant discussion, including links to publicly-available messages when applicable. The WGLC includes a paragraph with an IPR disclosure reminder. No additional disclosures were made after that. 13. Has each author, editor, and contributor shown their willingness to be listed as such? If the total number of authors and editors on the front page is greater than five, please provide a justification. yes 14. Document any remaining I-D nits in this document. Simply running the [idnits tool][8] is not enough; please review the ["Content Guidelines" on authors.ietf.org][15]. (Also note that the current idnits tool generates some incorrect warnings; a rewrite is underway.) UPDATE on -14: Nits on -11 have been addressed. OLD: No structural nits found. A few issues with clarity in -11 discovered and have been communicated to the authors. Copied here for reference: Section 3.1.1 states that “without the Control Sub-TLV .. the Session-Reflector does not add IPv6 extension headers” Section 5.3 states: .. MAY not add new matching IPv6 extension headers .. This behaviour can be based on a local policy on the Session-Reflector. I read the first sentence such that the reflector does not add them based on having seen them in the packet. And the second sentence as “the reflector might add headers that happen to match those in the TLVs for other reasons”. But the first sentence could lead one to expect a MUST NOT in 5.3. I think some more text to clarify the intent here would be good. Also, “MAY not add” sounds a bit strange as a normative phrase, perhaps “MAY omit” or similar is a bit clearer. Section 7 discusses attack mitigation by performing timestamp validation, giving the example of comparing T2 and T1. This comparison requires clock synchronization, perhaps it’s good to mention that, or use other examples like T3 >= T2 or T1 < T4. 15. Should any informative references be normative or vice-versa? See the [IESG Statement on Normative and Informative References][16]. No, the classifications look correct. 16. List any normative references that are not freely available to anyone. Did the community have sufficient access to review any such normative references? n/a 17. Are there any normative downward references (see [RFC 3967][9] and [BCP 97][10]) that are not already listed in the [DOWNREF registry][17]? If so, list them. No 18. Are there normative references to documents that are not ready to be submitted to the IESG for publication or are otherwise in an unclear state? If so, what is the plan for their completion? No, I-D.ietf-ippm-asymmetrical-pkts is in RFC Editors queue. 19. Will publication of this document change the status of any existing RFCs? If so, does the Datatracker metadata correctly reflect this and are those RFCs listed on the title page, in the abstract, and discussed in the introduction? If not, explain why and point to the part of the document where the relationship of this document to these other RFCs is discussed. No. 20. Describe the document shepherd's review of the IANA considerations section, especially with regard to its consistency with the body of the document. Confirm that all aspects of the document requiring IANA assignments are associated with the appropriate reservations in IANA registries. Confirm that any referenced IANA registries have been clearly identified. Confirm that each newly created IANA registry specifies its initial contents, allocations procedures, and a reasonable name (see [RFC 8126][11]). The draft does not request creation of any new registries. It asks for two TLV types in the "STAMP TLV Types registry and one Sub-TLV Type in the STAMP TLV Type "Reflected Test Packet Control" (Type 12). It should be noted that this TLV type is defined in ietf-ippm-asymmetrical-pkts which is currently in RFC Editors queue. 21. List any new IANA registries that require Designated Expert Review for future allocations. Are the instructions to the Designated Expert clear? Please include suggestions of designated experts, if appropriate. n/a [1]: https://www.ietf.org/about/groups/iesg/ [2]: https://www.rfc-editor.org/rfc/rfc4858.html [3]: https://www.rfc-editor.org/rfc/rfc7942.html [4]: https://wiki.ietf.org/group/ops/yang-review-tools [5]: https://www.rfc-editor.org/rfc/rfc8342.html [6]: https://wiki.ietf.org/group/iesg/ExpertTopics [7]: https://www.rfc-editor.org/info/bcp79 [8]: https://www.ietf.org/tools/idnits/ [9]: https://www.rfc-editor.org/rfc/rfc3967.html [10]: https://www.rfc-editor.org/info/bcp97 [11]: https://www.rfc-editor.org/rfc/rfc8126.html [12]: https://www.rfc-editor.org/rfc/rfc2026.html#section-5 [13]: https://www.rfc-editor.org/rfc/rfc2026.html#section-4.1 [14]: https://www.rfc-editor.org/rfc/rfc2026.html#section-4.2 [15]: https://authors.ietf.org/en/content-guidelines-overview [16]: https://www.ietf.org/about/groups/iesg/statements/normative-informative-references/ [17]: https://datatracker.ietf.org/doc/downref/ |
|
2026-09-18
|
14 | Rakesh Gandhi | New version available: draft-ietf-ippm-stamp-ext-hdr-14.txt |
|
2026-09-18
|
14 | Rakesh Gandhi | New version accepted (logged-in submitter: Rakesh Gandhi) |
|
2026-09-18
|
14 | Rakesh Gandhi | Uploaded new revision |
|
2026-09-09
|
13 | Thomas Graf | Notification list changed to marcus.ihlar@ericsson.com because the document shepherd was set |
|
2026-09-09
|
13 | Thomas Graf | Document shepherd changed to Marcus Ihlar |
|
2026-09-09
|
13 | Rakesh Gandhi | New version available: draft-ietf-ippm-stamp-ext-hdr-13.txt |
|
2026-09-09
|
13 | Rakesh Gandhi | New version accepted (logged-in submitter: Rakesh Gandhi) |
|
2026-09-09
|
13 | Rakesh Gandhi | Uploaded new revision |
|
2026-09-08
|
12 | Rakesh Gandhi | New version available: draft-ietf-ippm-stamp-ext-hdr-12.txt |
|
2026-09-08
|
12 | Rakesh Gandhi | New version accepted (logged-in submitter: Rakesh Gandhi) |
|
2026-09-08
|
12 | Rakesh Gandhi | Uploaded new revision |
|
2026-09-01
|
11 | Marcus Ihlar | Issue raised during shepherd review, revised ID likely required. |
|
2026-09-01
|
11 | Marcus Ihlar | Tag Other - see Comment Log set. |
|
2026-09-01
|
11 | Marcus Ihlar | # Document Shepherd Write-Up for Group Documents *This version is dated 4 July 2022.* Thank you for your service as a document shepherd. Among the … # Document Shepherd Write-Up for Group Documents *This version is dated 4 July 2022.* Thank you for your service as a document shepherd. Among the responsibilities is answering the questions in this write-up to give helpful context to Last Call and Internet Engineering Steering Group ([IESG][1]) reviewers, and your diligence in completing it is appreciated. The full role of the shepherd is further described in [RFC 4858][2]. You will need the cooperation of the authors and editors to complete these checks. Note that some numbered items contain multiple related questions; please be sure to answer all of them. ## Document History 1. Does the working group (WG) consensus represent the strong concurrence of a few individuals, with others being silent, or did it reach broad agreement? Broad agreement. 2. Was there controversy about particular points, or were there decisions where the consensus was particularly rough? Nothing especially controversial, good technical discussions. 3. Has anyone threatened an appeal or otherwise indicated extreme discontent? If so, please summarize the areas of conflict in separate email messages to the responsible Area Director. (It should be in a separate email because this questionnaire is publicly available.) no 4. For protocol documents, are there existing implementations of the contents of the document? Have a significant number of potential implementers indicated plans to implement? Are any existing implementations reported somewhere, either in the document itself (as [RFC 7942][3] recommends) or elsewhere (where)? There is one open source implementation mentioned in the draft. ## Additional Reviews 5. Do the contents of this document closely interact with technologies in other IETF working groups or external organizations, and would it therefore benefit from their review? Have those reviews occurred? If yes, describe which reviews took place. This is document is very much in IPPM territory, there has been a Performance metric directorate review that was very helpful in improving the document. Relations to intarea are superficial since while it's about reflecting IP headers there are no impacts on intermediate node behavior in terms of reading or processing headers. 6. Describe how the document meets any required formal expert review criteria, such as the MIB Doctor, YANG Doctor, media type, and URI type reviews. n/a 7. If the document contains a YANG module, has the final version of the module been checked with any of the [recommended validation tools][4] for syntax and formatting validation? If there are any resulting errors or warnings, what is the justification for not fixing them at this time? Does the YANG module comply with the Network Management Datastore Architecture (NMDA) as specified in [RFC 8342][5]? n/a 8. Describe reviews and automated checks performed to validate sections of the final version of the document written in a formal language, such as XML code, BNF rules, MIB definitions, CBOR's CDDL, etc. n/a ## Document Shepherd Checks 9. Based on the shepherd's review of the document, is it their opinion that this document is needed, clearly written, complete, correctly designed, and ready to be handed off to the responsible Area Director? The shepherd has found a possible wireformat issue in version 11 of the document. This issue has been communicated to the authors and the WG. Once this issue is resolved the document is ready to be handed off. 10. Several IETF Areas have assembled [lists of common issues that their reviewers encounter][6]. For which areas have such issues been identified and addressed? For which does this still need to happen in subsequent reviews? This mechanism touches on possible MTU issues, and have solutions for it. Could be something for a TSVART reviewer to look at. 11. What type of RFC publication is being requested on the IETF stream ([Best Current Practice][12], [Proposed Standard, Internet Standard][13], [Informational, Experimental or Historic][14])? Why is this the proper type of RFC? Do all Datatracker state attributes correctly reflect this intent? Proposed Standard. This is an extension to a mature and largely deployed protocol. Datatracker state attributes reflect this intent correctly. 12. Have reasonable efforts been made to remind all authors of the intellectual property rights (IPR) disclosure obligations described in [BCP 79][7]? To the best of your knowledge, have all required disclosures been filed? If not, explain why. If yes, summarize any relevant discussion, including links to publicly-available messages when applicable. The WGLC includes a paragraph with an IPR disclosure reminder. No additional disclosures were made after that. 13. Has each author, editor, and contributor shown their willingness to be listed as such? If the total number of authors and editors on the front page is greater than five, please provide a justification. pending. 14. Document any remaining I-D nits in this document. Simply running the [idnits tool][8] is not enough; please review the ["Content Guidelines" on authors.ietf.org][15]. (Also note that the current idnits tool generates some incorrect warnings; a rewrite is underway.) No structural nits found. A few issues with clarity in -11 discovered and have been communicated to the authors. Copied here for reference: Section 3.1.1 states that “without the Control Sub-TLV .. the Session-Reflector does not add IPv6 extension headers” Section 5.3 states: .. MAY not add new matching IPv6 extension headers .. This behaviour can be based on a local policy on the Session-Reflector. I read the first sentence such that the reflector does not add them based on having seen them in the packet. And the second sentence as “the reflector might add headers that happen to match those in the TLVs for other reasons”. But the first sentence could lead one to expect a MUST NOT in 5.3. I think some more text to clarify the intent here would be good. Also, “MAY not add” sounds a bit strange as a normative phrase, perhaps “MAY omit” or similar is a bit clearer. Section 7 discusses attack mitigation by performing timestamp validation, giving the example of comparing T2 and T1. This comparison requires clock synchronization, perhaps it’s good to mention that, or use other examples like T3 >= T2 or T1 < T4. 15. Should any informative references be normative or vice-versa? See the [IESG Statement on Normative and Informative References][16]. No, the classifications look correct. 16. List any normative references that are not freely available to anyone. Did the community have sufficient access to review any such normative references? n/a 17. Are there any normative downward references (see [RFC 3967][9] and [BCP 97][10]) that are not already listed in the [DOWNREF registry][17]? If so, list them. No 18. Are there normative references to documents that are not ready to be submitted to the IESG for publication or are otherwise in an unclear state? If so, what is the plan for their completion? No, I-D.ietf-ippm-asymmetrical-pkts is in RFC Editors queue. 19. Will publication of this document change the status of any existing RFCs? If so, does the Datatracker metadata correctly reflect this and are those RFCs listed on the title page, in the abstract, and discussed in the introduction? If not, explain why and point to the part of the document where the relationship of this document to these other RFCs is discussed. No. 20. Describe the document shepherd's review of the IANA considerations section, especially with regard to its consistency with the body of the document. Confirm that all aspects of the document requiring IANA assignments are associated with the appropriate reservations in IANA registries. Confirm that any referenced IANA registries have been clearly identified. Confirm that each newly created IANA registry specifies its initial contents, allocations procedures, and a reasonable name (see [RFC 8126][11]). The draft does not request creation of any new registries. It asks for two TLV types in the "STAMP TLV Types registry and one Sub-TLV Type in the STAMP TLV Type "Reflected Test Packet Control" (Type 12). It should be noted that this TLV type is defined in ietf-ippm-asymmetrical-pkts which is currently in RFC Editors queue. 21. List any new IANA registries that require Designated Expert Review for future allocations. Are the instructions to the Designated Expert clear? Please include suggestions of designated experts, if appropriate. n/a [1]: https://www.ietf.org/about/groups/iesg/ [2]: https://www.rfc-editor.org/rfc/rfc4858.html [3]: https://www.rfc-editor.org/rfc/rfc7942.html [4]: https://wiki.ietf.org/group/ops/yang-review-tools [5]: https://www.rfc-editor.org/rfc/rfc8342.html [6]: https://wiki.ietf.org/group/iesg/ExpertTopics [7]: https://www.rfc-editor.org/info/bcp79 [8]: https://www.ietf.org/tools/idnits/ [9]: https://www.rfc-editor.org/rfc/rfc3967.html [10]: https://www.rfc-editor.org/info/bcp97 [11]: https://www.rfc-editor.org/rfc/rfc8126.html [12]: https://www.rfc-editor.org/rfc/rfc2026.html#section-5 [13]: https://www.rfc-editor.org/rfc/rfc2026.html#section-4.1 [14]: https://www.rfc-editor.org/rfc/rfc2026.html#section-4.2 [15]: https://authors.ietf.org/en/content-guidelines-overview [16]: https://www.ietf.org/about/groups/iesg/statements/normative-informative-references/ [17]: https://datatracker.ietf.org/doc/downref/ |
|
2026-07-16
|
11 | Marcus Ihlar | IETF WG state changed to WG Consensus: Waiting for Write-Up from In WG Last Call |
|
2026-07-04
|
11 | Rakesh Gandhi | New version available: draft-ietf-ippm-stamp-ext-hdr-11.txt |
|
2026-07-04
|
11 | Rakesh Gandhi | New version accepted (logged-in submitter: Rakesh Gandhi) |
|
2026-07-04
|
11 | Rakesh Gandhi | Uploaded new revision |
|
2026-06-26
|
10 | Rakesh Gandhi | New version available: draft-ietf-ippm-stamp-ext-hdr-10.txt |
|
2026-06-26
|
10 | Rakesh Gandhi | New version accepted (logged-in submitter: Rakesh Gandhi) |
|
2026-06-26
|
10 | Rakesh Gandhi | Uploaded new revision |
|
2026-06-19
|
09 | Rakesh Gandhi | New version available: draft-ietf-ippm-stamp-ext-hdr-09.txt |
|
2026-06-19
|
09 | Rakesh Gandhi | New version accepted (logged-in submitter: Rakesh Gandhi) |
|
2026-06-19
|
09 | Rakesh Gandhi | Uploaded new revision |
|
2026-06-17
|
08 | Xiao Min | Request for Early review by PERFMETRDIR Completed: Has Issues. Reviewer: Xiao Min. Sent review to list. |
|
2026-06-04
|
08 | Marcus Ihlar | IETF WG state changed to In WG Last Call from WG Document |
|
2026-06-04
|
08 | Thomas Graf | Request for Early review by PERFMETRDIR is assigned to Xiao Min |
|
2026-06-04
|
08 | Thomas Graf | Requested Early review by PERFMETRDIR |
|
2026-05-04
|
08 | Rakesh Gandhi | New version available: draft-ietf-ippm-stamp-ext-hdr-08.txt |
|
2026-05-04
|
08 | Rakesh Gandhi | New version accepted (logged-in submitter: Rakesh Gandhi) |
|
2026-05-04
|
08 | Rakesh Gandhi | Uploaded new revision |
|
2025-11-06
|
07 | Rakesh Gandhi | New version available: draft-ietf-ippm-stamp-ext-hdr-07.txt |
|
2025-11-06
|
07 | Rakesh Gandhi | New version accepted (logged-in submitter: Rakesh Gandhi) |
|
2025-11-06
|
07 | Rakesh Gandhi | Uploaded new revision |
|
2025-10-05
|
06 | Rakesh Gandhi | New version available: draft-ietf-ippm-stamp-ext-hdr-06.txt |
|
2025-10-05
|
06 | Rakesh Gandhi | New version accepted (logged-in submitter: Rakesh Gandhi) |
|
2025-10-05
|
06 | Rakesh Gandhi | Uploaded new revision |
|
2025-06-18
|
05 | Rakesh Gandhi | New version available: draft-ietf-ippm-stamp-ext-hdr-05.txt |
|
2025-06-18
|
05 | Rakesh Gandhi | New version accepted (logged-in submitter: Rakesh Gandhi) |
|
2025-06-18
|
05 | Rakesh Gandhi | Uploaded new revision |
|
2025-06-02
|
04 | Rakesh Gandhi | New version available: draft-ietf-ippm-stamp-ext-hdr-04.txt |
|
2025-06-02
|
04 | Rakesh Gandhi | New version accepted (logged-in submitter: Rakesh Gandhi) |
|
2025-06-02
|
04 | Rakesh Gandhi | Uploaded new revision |
|
2025-05-09
|
03 | Rakesh Gandhi | New version available: draft-ietf-ippm-stamp-ext-hdr-03.txt |
|
2025-05-09
|
03 | Rakesh Gandhi | New version accepted (logged-in submitter: Rakesh Gandhi) |
|
2025-05-09
|
03 | Rakesh Gandhi | Uploaded new revision |
|
2025-03-18
|
02 | Rakesh Gandhi | New version available: draft-ietf-ippm-stamp-ext-hdr-02.txt |
|
2025-03-18
|
02 | Rakesh Gandhi | New version accepted (logged-in submitter: Rakesh Gandhi) |
|
2025-03-18
|
02 | Rakesh Gandhi | Uploaded new revision |
|
2025-02-11
|
Tess Chapeta | Posted related IPR disclosure Huawei Technologies Co.,Ltd's Statement about IPR related to draft-ietf-6man-icmpv6-reflection and draft-ietf-ippm-stamp-ext-hdr | |
|
2024-10-16
|
Tess Chapeta | Posted related IPR disclosure Huawei Technologies Co.,Ltd's Statement about IPR related to draft-wang-ippm-stamp-hbh-extensions and draft-ietf-ippm-stamp-ext-hdr | |
|
2024-10-14
|
01 | Rakesh Gandhi | New version available: draft-ietf-ippm-stamp-ext-hdr-01.txt |
|
2024-10-14
|
01 | Rakesh Gandhi | New version accepted (logged-in submitter: Rakesh Gandhi) |
|
2024-10-14
|
01 | Rakesh Gandhi | Uploaded new revision |
|
2024-06-28
|
Tess Chapeta | Posted related IPR disclosure Cisco Systems, Inc.'s Statement about IPR related to draft-ietf-ippm-stamp-ext-hdr | |
|
2024-05-30
|
00 | Tommy Pauly | This document now replaces draft-gandhi-ippm-stamp-ext-hdr instead of None |
|
2024-05-30
|
00 | Rakesh Gandhi | New version available: draft-ietf-ippm-stamp-ext-hdr-00.txt |
|
2024-05-30
|
00 | Tommy Pauly | WG -00 approved |
|
2024-05-30
|
00 | Rakesh Gandhi | Set submitter to "Rakesh Gandhi ", replaces to draft-gandhi-ippm-stamp-ext-hdr and sent approval email to group chairs: ippm-chairs@ietf.org |
|
2024-05-30
|
00 | Rakesh Gandhi | Uploaded new revision |